Protected: Update TopGPL backend

There is no excerpt because this is a protected post.